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SuperReport Pro Objects

SuperReport Pro's toolbar contains tools which enable you to create and manipulate objects (such as fields
and variables) which are used in all reports.

These tools (reading from left to right) are:

arrow tool for selecting, resizing and dragging objects
text tool for adding new static text items
field tool for adding new fields from the database
variable tool for adding new variable from the database
line tool for drawing either horizontal or vertical lines
box tool for drawing rectangles (and/or grids)
circle tool for drawing circles
alignment tool for aligning selected objects (a pop-up menu appears)

Creating A New Object
Within the exception of the alignment tool, these icons are used to create and manipulate objects on the
report. To create an object on the report, select the appropriate tool and drag a rectangle defining the new
object.

Selecting Objects
Selecting an object is achieved by first selecting the arrow (selection) tool, and then by clicking on the
appropriate object within the report. When an object is selected it will be drawn with "handles" at each
corner.

To de-select an already selected object, click on it while holding down the Shift key. Clicking on the object
again with the Shift key will again select the object. If you click on part of the report that contains no
objects (without the Shift key down), any selected objects will become de-selected.

If you wish to select a group of objects quickly, then you can click on the report page (but not on an object)
and drag a "marquee" over the objects to be selected - any objects that are touched by or are within the
marquee will become selected. Any previously selected objects will become de-selected unless you are
holding down the Shift key in which case the newly selected objects will be added to those previously
selected.

Moving Objects
If you click within an object that is already selected, then SuperReport Pro will assume that you wish to
move the object, and will allow you to drag it around. If more than one object is selected, then all the
selected objects will be moved.

SuperReport Pro also allows you to "nudge" objects using the cursor keys. If you have selected one or more
objects, and you press either of the four cursor (arrow) keys, the selected objects will be moved by one
pixel in the direction of the cursor key. For example, if you press the up arrow cursor key the selected
objects will be moved up by one pixel. Holding down the Option key while pressing any of the cursor keys
will cause the selected objects to be nudged by ten pixels instead of one pixel.

Resizing Objects
If you click within the object's "handles" then SuperReport Pro will assume that you wish to resize the
object, and will allow you to drag the corner around, until you release the mouse button. When creating a
new object on the label, or resizing an existing object, holding down the Shift key has the effect of making
the height and width of the object the same (as the object is dragged). This feature is useful for creating
squares (as opposed to rectangles) and circles (as opposed to ovals).
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Objects can also be resized using the cursor keys. If you hold down the Command key while pressing any of
the cursor keys, any selected objects will be resized. Pressing the Option key as well will cause the object
to be resized by ten pixels as opposed to one pixel. When the up arrow or down arrow cursor keys are
pressed, the lower boundary of the selected objects will be resized in a vertical direction, and when the left
arrow or right arrow cursor keys are pressed, the right hand boundary of the selected objects will be
resized in a horizontal direction.

Aligning Objects
To align two or more selected objects on the report, click in the alignment icon within the toolbar, and
hold the mouse button down. An alignment pop-up menu will appear allowing you to specify how you want
the selected objects aligned. While keeping the mouse button pressed down, you may drag the mouse within
the pop-up menu to select the alignment that you want, then release the mouse. If you drag the mouse
outside of the pop-up menu and release the mouse, no alignment will take place.

Reading from top left to bottom left in a clockwise direction the six alignment options are: left aligned,
align tops, align vertical centres, align horizontal centres, align bottoms, and right aligned. Note that the
alignment of objects is different from the alignment of text within an object.

Setting the Pattern and Colour of Objects
SuperReport Pro allows you to specify the pattern and colour of objects; both the for the object's "fill" and
for the object's border. The pattern and colour pop-up icons next to the pen symbol are used to change the
object's border attributes, while the pattern and colour pop-up icons next to the paint pot symbol are
used to change the object's fill attributes.

Changing the Line Thickness of Objects
SuperReport Pro allows you to specify the line thickness of lines, rectangles and ovals using the Line
Thickness selection area. To change the lines thickness of one or more objects, select the object or objects,
and select the required line thickness from the line thickness pop-up icon. Line thicknesses may be a
hairline, or 1 point up to 8 point in thickness.

Changing the line thickness only applies to lines, and the borders of rectangles and circles - it has no
meaning for other object types.

Setting an Object's Text Attributes
SuperReport Pro allows you to control the text attributes of objects, fields and variables that contain text.
You may determine the font, the size, the style and the justification of text within the object. An object's
text attributes are set "globally" for the object - you may not make particular words within the object
have different text attributes. To change the text attributes for one or more objects, first select the object
or objects, and then use the appropriate text options shown in the toolbar (above).

To change the font of an object, click on the pop-up arrow 
marker to the left of the font name (shown as "Geneva" above). A pop-up menu will appear listing all the
fonts available within your system. The object's font will be changed to whichever new font you select.

To change the font size of an object, click on the pop-up arrow marker to the left of the font size (shown as
"9 Pt" above). A pop-up menu will appear listing all the fonts sizes available within your system. If you
select the Other… item from the pop-up menu, then a dialog will appear allowing you to enter a font size
between 1 and 144 points - fractional fonts are not supported. The object's font size will be changed to
whichever new font you select.

To change the font style of an object, click within one the font style boxes. 
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You are able to choose between plain text, bold text, underlined text, italic text, outlined text and
shadowed text, or any of these styles in any combination.

When changing the font, size or style of an object, SuperReport will adjust the bottom of the object to
accommodate a "whole" number of lines of text for your chosen font, size and style combination.

To change the justification of text within an object, click within one of the three 
justification options (the three icons at the top right of the toolbar). The three available justifications are
left, centre and right justified (reading from left to right).

Whenever you select one or more objects, SuperReport will "show" you the font, size, style and
justification of the selected objects using the text tools in the toolbar. If you select two text objects, one of
which is Geneva 9 pt and the other Helvetica 9 pt, then SuperReport will not show a font name (since the
fonts are different), but will show the font size as "9 Pt" since this is a common attribute for both objects.

If you wish to change the default font, size, style and justification for new text objects, then make the text
attribute changes when no objects are selected. Any new text objects that are subsequently created will take
the new default attributes.
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Text Objects

Adding a Text Object
Select the Text icon from the toolbar, and drag the text object's rectangle within the report. Once you
release the mouse button, a dialog will appear allowing you to enter the static text that you want to appear
within the rectangle, and to set the object's positioning options (using the check boxes). The text
positioning options are described below in the section Object Positioning.
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Field Objects

Adding a Field
Select the Field icon from the toolbar, and drag the field's rectangle within the report. Once you release
the mouse button, a dialog will appear allowing you to name the field, to select the print formatting (for
number, date, time, boolean and picture fields), and to set the object's positioning options (using the check
boxes).

To name the field, choose a field from the file/field pop-up menu that is displayed when you click on the
pop-up menu icon to the right of the word "Field".

For number, date, time, boolean and picture fields, you may select one of the predefined formats from the
pop-up menu that will appear when you click on the pop-up menu icon to the right of the word "Format".
You may enter your own format string directly in the Format text area instead of using one of the
predefined formats, if you wish. See the section on Object Formatting below.

The field positioning options are described below in the section Object Positioning.

The buttons that deal with the object's calculated, repeating attributes, and script are dealt with later. An
explanation of the scripting capabilities for objects is also described later. See the sections on Automatic
Calculations For Objects, Repeating Objects, and Scripts.
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Variable Objects

Adding a Variable
Select the Variable icon from the toolbar, and drag the variable's rectangle within the report. Once you
release the mouse button, a dialog will appear allowing you to name the variable, to select the print
formatting (for number, date, time, boolean and picture fields), and to set the object's positioning options
(using the check boxes).

To name the variable, choose a variable from the variable names pop-up menu that is displayed when you
click on the pop-up menu icon to the right of the word "Variable". If the variable names pop-up menu is
not active, or you wish to use a variable not listed in the menu, you may enter the variable name directly
into the Variable name text area.

You may specify the type of the variable using the Type pop-up menu. SuperReport Pro supports three
types of variable and variable access. These are "variable", "array (automatic)", and "array element".

For number, date, time, boolean and picture variables, you may select one of the predefined formats from a
pop-up menu that will appear when you click on the pop-up menu icon to the right of the word "Format".
You may enter your own format string directly in the Format text area instead of using one of the
predefined formats, if you wish. See the section on Object Formatting below.

The variable positioning options are described below in the section Object Positioning.

The buttons that deal with the object's calculated, repeating attributes, and script are dealt with later. An
explanation of the scripting capabilities for objects is also described later. See the sections on Automatic
Calculations For Objects, Repeating Objects, and Scripts.
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Object Formatting

Object Formatting Strings
The object formatting strings are the values that are entered into the Format text area - these are used at
print time to format the object's text according to the object's data type.

Format String Displayed As

Date format strings:
Short 1/1/92
Abbrev Mon, Jan 1, 1992
Long Monday, January 1, 1992
Short2 01/01/1992

Time format strings:
12:24:15 12:24:15
12:24 12:24
12 hrs 24 min 15 secs 12 hours 24 minutes 15 seconds
12 hours 24 minutes 12 hours 24 minutes
12:24 pm 12:24 pm

Boolean format strings:
yes;no
Married;Single
Has children
;Not Required

A boolean value that evaluates to TRUE will have the "yes" text substituted at print time, while a FALSE
value will have the "no" text substituted. The text for TRUE and FALSE format strings lie on the left and the
right of the separating semi-colon (";") and can be any or no text.

Numeric format strings:
(Reals, Integers and Longints) positive;negative;zero
US$###,###0.00
000,000.00;(000,000.00);0.00
$^^ ,̂̂ ^ ,̂̂ ^0.00

The semi-colons separate format strings for positive, negative and zero numbers. The following four
symbols are place-holders, #, 0, ^, *. The following table illustrates the effect that the place-holder has
on leading or trailing zeros.

# No effect
0 Displays 0
^ Displays a "hard" space (ASCII 202)
* Displays a *

If you are to print large numbers, be sure to ensure that you provide sufficient place holders otherwise the
numeric value will be printed as "<<<<<<".

Picture format strings:
Normal Right and bottom edges may be clipped
Centered All edges may be clipped
Scaled Picture scaled within object's rectangle
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Scaled (Proportional) Picture scaled proportionally
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Object Positioning

Field and Variable Object Positioning
SuperReport Pro allows you to control the relative positioning of any object within the printed report, or
to fix an object's position. Field and Variable objects have more options that allow you to control the width
and depth of the object and the object's effect on other objects. These options are available to you when you
create the object, or if you double-click within the object, or by selecting the object and choosing the
Modify Object… command from the Edit menu.

The Fix Horizontal and Fix Vertical check boxes allow you to fix either the horizontal or vertical
position of the object, or both, in relation to the other objects on the report. Any adjustment in a object's
rectangle at print time may cause an appropriate adjustment to other objects at print time unless their
Fix Horizontal and Fix Vertical check boxes are checked.

If you have an object near the bottom of the report, and have also defined a text field object above with the
Print With Variable Depth option set, you would use the Fix Vertical setting (in the lower object)
to ensure that it remained at its current position, regardless of how small or large the text field object
above became at print time as a result of the amount of text within it. Otherwise, the lower object would
either be "pulled up" or "pushed down" in sympathy with the rectangle changes of the text field object
above.

The Print With Variable Depth option will cause SuperReport Pro to extend the bottom boundary of
the object's rectangle sufficiently to accommodate the field or variable text. This enables you to define a
field or variable object as only one line in height, set the Print With Variable Depth option (by
checking the check box), and let SuperReport Pro adjust the object's rectangle for you. If the object's
rectangle is either contracted upwards or extended downward to accommodate the text, then any objects
below that object will be repositioned accordingly unless their Fix Vertical setting is set, even if they
are not directly beneath the 'variable depth' object but are still below it to either side.

The Print With Variable Width option will cause SuperReport Pro to extend the right boundary of the
object's rectangle sufficiently to accommodate the field or variable text. Again, like the Print With
Variable Depth option described above, this will cause any other objects at the same height on the report,
and to the right of the original object to be displaced horizontally in sympathy with the object's shrinking
or stretching unless their Fix Horizontal setting is set.

When the Print With Variable Width option is set, and the field or variable object is empty (i.e.
contains no text) then SuperReport Pro will automatically "pull" the next object to its right into its
position. This is useful for example when you place three fields Title, Firstname and Surname on the same
line and let SuperReport Pro take care of the fact that for some records you may have the title or firstname
missing.

The Print With Variable Depth and Print With Variable Width options are mutually exclusive. In
other words you may not have both these options set at the same time. If you set one, and the other option is
already set then SuperReport Pro will automatically unset the other for you.

The If Empty, Replace By Items Below option allows you to "collapse" an empty object, replacing it
by the next item below, and pulling up any other items below by the height of the "collapsed" object. Again,
setting the Fix Vertical Position option in any of the items below will prevent them from being "pulled
up". The If Empty, Replace By Items Below option is useful for addresses where the address is
broken into individual lines, some of which may be empty. Using this option SuperReport Pro will generate
the address with any blank lines automatically removed.
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Graphics & Picture Objects

Adding a Picture
To add a graphic, such as a logo, to the report, copy the graphic from the Scrapbook, or your graphics
application to the Clipboard (using the Copy command on the Edit menu) and make the SuperReport Pro
editor area active, and select the Paste command from the Edit menu. The graphic will be pasted onto the
report. You can then move the graphic and resize it as necessary.

If you double click on the graphic, SuperReport Pro will display the pictures options dialog, Using the
options available within the dialog, you can control how the picture is displayed within the object
rectangle, and fix the object’s positioning if required.

The illustration below shows four graphics. The original graphic is the leftmost graphic, the other three
reading from left to right are displayed using the Normal, Centered and Scaled To Fit options, and show the
effect that these display options have when the original graphic is resized.

SuperReport Pro supports both PICT and PICT2 images.
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Other Object Operations

Changing an Object’s Options
To change an object’s options, either double-click on the object, or select the object and choose the Modify
Object command on the Edit menu.

A dialog will appear allowing you to change the object’s options. Different dialogs appear for different types
of objects, although all the object options dialogs have the Fix Horizontal Position and Fix Vertical
Position check boxes in common.

Rearranging Objects
There are four commands on the Edit menu, Send To Back, Send Backwards, Bring To Front and
Bring Forwards that allow you to place an object behind or in front of an object that it overlaps with. To
use any of these commands, select a single (or multiple) objects, and then select the appropriate command.

Rearranging objects is used to ensure that the objects are drawn in the correct sequence on your reports.
However this feature is also useful for reports that are printed to disk, since the order of the objects
determines the order in which the objects are exported.

If you need to "see" the object order, then select the Show Object Order command from the Options
menu.

Selecting an Object hidden behind another
To select an object hidden behind another without having to send the frontmost object behind (using the
Send To Back command), hold down the Command key while clicking on the object you wish to select.
Pressing the Command key down causes SuperReport Pro to select the rearmost object, rather than the
frontmost object (which it does by default). Similarly, if you wish to double-click on an object hidden
behind another (to display the object’s options dialog), press the Command key down while double-
clicking.

Duplicating an Object
To duplicate one or more objects from the report, first select the objects to be duplicated and then select
the Duplicate command from the Edit menu.

Deleting an Object
To delete one or more objects from the report, first select the objects to be deleted and then press the
Delete key or select the Clear command from the Edit menu. If you need to undo this operation, select the
Undo  command from the Edit menu.

Changing an Object from one type to another
To change an object from one type to another, select the object and select the Change Object…  command
from the Edit menu. A dialog will appear allowing you to change the object to a new type. This feature is
sometimes useful for changing fields to variables and vice-versa.

Undoing the last action in the Report Editor
The last action performed in the report editor may be undone using the Undo  command on the Edit menu.
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Automatic Calculations For Objects

Changing an Object’s Options
SuperReport Pro provides a facility for the automatic calculation (such as totalling) of numeric fields and
variables. To make use of this capability, you should click on the Calculate… button in the field or
variable object options dialog.

This will produce the calculate options dialog like the one show above. Using the radio buttons, you may
select the type of calculation that you wish to have performed.

If you also need to make use of the calculated value in any report or object scripts then check the Record
Value In Variable check box, and specify the variable name in the edit field provided (or select a
variable from the pop up menu icon.
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Once you have selected a calculation type, the Calculate button will have a  (tick mark) in it to signify
that an automatic calculation has been specified.

If the object is in a Total or SubTotal1 … SubTotal6 section, then you can select the Show Calculated
Value check box which will cause SuperReport Pro to show the calculated value that is appropriate for
that section.

Normally objects to be totalled are placed in the Body section of the report with an automatic calculation
specified. And objects which are to display the subtotal value (instead of the current value) are normally
placed in either the SubTotal1 … SubTotal6  or Total sections, and will have the Show Calculated
Value check box checked. However there is no requirement for the object to be placed in the Body section,
if you only wish to have the calculated value shown in a SubTotal1 … SubTotal6  or Total section.

Before the report is generated SuperReport Pro will scan all objects defined on the report seeing whether
they require automatic calculations and will then maintain a calculation table for those objects while the
report is generated.

Automatic calculations can be used for totalling objects, or to produce minimum, maximum, or average
values. And they can be used for either field, array or variable objects.
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Repeating Objects

What Are Repeating Objects?
SuperReport Pro performs special actions for objects that have their 'Repeating Object' attribute switched
on. The only objects that may have this attribute set are fields, and arrays - setting this attribute for
(non-array) variables is not meaningful. Repeating objects can be used to display information from other
files or arrays in a column format (in much the same way that 4D does with included layouts, but with a lot
less hassle).

For example, each invoice in a 4th Dimension database might have one or more invoice items belonging to
it. If a report was created to print invoices, it would be possible to show the invoice items for each invoice
using the repeating object attribute for the [Item] fields.

Normally repeating objects are placed in the Body section of a report. They are ignored if placed in the
Footer section of the report.

As the Body section is processed for each [Invoice] record, SuperReport Pro computes the number of
repetitions of the repeating [Item] fields based upon the number of records in the [Item] file selection. The
second and subsequent repetition of a repeating object will (usually) be placed immediately beneath the
previous (or first) instance of the object. In other words, repeating objects repeat downward resulting in
columns of repeated data - although SuperReport Pro allows objects to repeat horizontally as well.
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When you hit the Repeat… button in the object options dialog, the repeating options dialog will appear.
Here you are able to specify whether you wish the object to repeat or not, and if so whether to repeat either
horizontally or vertically. If you do specify that the object is to 'repeat', then the Repeat… button will be
shown with a  (tick mark) in it.

You can use the Body Script… command (on a hierarchical menu displayed when you select the Scripts
command from the SuperReport menu) to create a procedure or script to load or search for the related
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records, and to sort them if you wish, prior to printing the Body section. The same script could also be
used to create and load arrays with information to be printed using repeating objects.

When SuperReport Pro encounters a repeating object in a section, it calculates the number of iterations
required for that object, and then will generate as many (new) repeating objects as there are iterations,
placing the new objects in a position from its predecessor as defined in the Repeating Options dialog.
SuperReport Pro will also adjust the section height to cater for the extra repeating objects that have been
placed on the page as the report is generated.

Repeating objects provide a similar capability to 4th Dimension’s included layouts, but are much simpler
to use.

If you do not wish to use repeating objects, then you can define your report in such a way that (in this
example), the [Item] file is the main file, and the [Invoice] information is displayed in a SubHeader and
SubFooter sections. The diadvantage of this method is that it requires that you make use of break
processing, and it requires more work.
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Object, Section and Report Scripts

Scripts
SuperReport Pro allows you to attach an object script to any field or variable object, or section.

To access the script editor window, click on the Script… button in the object options dialog. If the object
already has a script associated with it, or if you create a new script for the object then the text of the
Script… button will be preceded by a  (tick mark). The tick mark is a quick way of seeing that an object
has a script associated with it.

When an object is viewed on the report page, it is also possible to tell whether it has a script attached to it
or not. If it does have a script then the top left handle corner of the object will have an inverted triangle
visible - the same is also true for sections that have scripts attached.

When the report is generated, object scripts are executed 'just before' they are printed on the report. For
example, if an object is in the Body section of a report, and the report prints the Body section five times
(because the report is printing a selection of five records), then the object script will be executed five
times - each time prior to the object being printed on the page. Object scripts are always executed when
defined, even if the section that the object is in is suppressed (for printing using the Select Printing
Sections… commands on the SuperReport menu).

Object scripts can be used to make selections of records in other files, to fill variables with data, or to
perform any other action that the 4th Dimension command set will allow.
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The SuperReport Pro script editor window appears whenever you select the Script… button from the object
options dialog, or from the Section Options dialog, or when you select one of the hierarchical menu items from
the Scripts command on the SuperReport menu.

The script editor window contains a text entry field where 4th Dimension statements can be entered. A script
may contain one or more lines of valid 4th Dimension statements.

SuperReport Pro neither 'pretty prints' the text in this area nor checks the syntax of the statements that you
enter. Each line must contain a self-contained 4th Dimension statement because SuperReport Pro does not
support any loop or conditional structures. For example the following statements are NOT valid when entered
in the script editor window:

If (Size of array(aName)>0)
   For ($k;1;Size of array(aName))
      aName{$k}:=""
   End For
End If

If you need to execute statements requiring either loop or conditional structures, you should create a procedure
within your 4th Dimension database to perform the action and call the procedure from SuperReport Pro by
entering the procedure name within the script editor window.

The script editor window contains an OK and Cancel button. These are used to save or cancel any changes that
you make to the scripts.

The three icons at the bottom left of the dialog window may be clicked on to provide pop-up menus listing the
4th Dimension command set, the file structure contained within the 4th Dimension database, and a list of
variables used within the database. Selecting an item from any of these pop-up menus will insert the relevant
text into the text above.
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Report Sections

Sections
A SuperReport Pro report document is broken up into different sections. These sections are the Header
section, SubHeader sections, Body section, Subtotal sections, Total section and Footer section. There
are six SubHeader sections named SubHeader1, SubHeader2 … SubHeader6 and six SubTotal
sections named SubTotal1, SubTotal2 … SubTotal6.

A report always has the following sections; a Header section, a Body section, a Total section and a Footer
section. The SubHeader and SubTotal sections are optional and are only used when break processing is to
take place - in fact these two types of section are used to define the number of break levels and when the
breaks will occur.

Sections occur on a report in the following order:

Header
SubHeader1
SubHeader2
SubHeader3
SubHeader4
SubHeader5
SubHeader6

Body
SubTotal6
SubTotal5
SubTotal4
SubTotal3
SubTotal2
SubTotal1

Total
Footer

Those sections not shown in bold are optional and are not required on a report. The other sections occur on
all reports. When SuperReport Pro is launched and a blank document is displayed, the four standard
sections (Header, Body, Total and Footer) are always automatically created.

The Header section marker marks the bottom of the header section of the report. Everything from the top
of the page to the Header section marker is in the Header section. The Header section of the report and
the objects within that region are printed at the top of every page that is generated by SuperReport Pro.
Similarly, the region between the Total section marker and the Footer section marker and the objects
contained within that region are printed at the bottom of every page that is generated.

A section region is bounded at its bottom by the section marker of the same name, and at the top by the
section marker above.

Where are the Sections used in the printed Report?
The Header section and its objects (those contained within the section) are printed at the top of every page
of the report that is generated by SuperReport. The SubHeader sections SubHeader1, SubHeader2 …
SubHeader6 are described later. The Body section and its objects are printed for each iteration, or for
each record of the selection that is processed. The SubTotal sections SubTotal1, SubTotal2 …
SubTotal6 are also described later. The Total section and its objects are printed after the final iteration,
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or after the last record in the selection and its Body section has been printed. The Footer section and its
objects are printed at the bottom of every page of the report that is generated by SuperReport Pro.

Moving the Sections
To move a section marker, either click on the section marker’s line, or on the rectangle that contains the
section’s name. SuperReport Pro will allow you to move the section horizontally without restriction, and
vertically up as far as the section marker above, and down as far as the section marker below. In the
example shown, you are not able to move the Body marker above the Header marker, nor below the Total
marker.

If you hold the Shift key while dragging the section markers, then ALL the sections markers beneath the
selected one will be moved in sympathy with it. For example, dragging the Body section marker while
holding the Shift key would cause the Total and Footer markers to move in sympathy.

Selecting the Positions Sections… command from the Edit menu will produce a dialog that allows you to
quickly set the horizontal position of the section marker rectangles (these contain the section name). Using
the dialog, you may place the section marker rectangles at the left of the editor area, staggered across the
editor, or at the right hand edge of the editor area. This facility is useful if you find the section markers
obscuring parts of the report.

You can also show or hide the sections using the Show Sections command on the Options menu. The Lock
Sections command on the Options menu is used to prevent the sections from being moved or modified by
accident.

Creating and Deleting SubHeader and SubTotal Sections
To add or delete sections use the Add/Delete Sections… command from the Edit menu. Using the dialog
that appears, you are able to add or remove sections by checking the appropriate checkboxes.
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Break Processing
SuperReport Pro's break processing capability will enable you to print report subheadings, subtotals and
grand totals for the entire record or array selection to be printed provided that the record or array
selection is sorted appropriately.

Assume the following record information sorted alphabetically by region, and by customer name within
region:

[Customer]Name [Customer]Region [Customer]Sales
Mission Computers Central 15,000
GTec Systems London 100,000
MacGregorTech London 85,000
Dartmouth Shipping West Country 8,000
Great Combe Systems West Country 25,000
River Down Ltd West Country 156,000

And that a report is required in the following format:

Region Central
Mission Computers 15,000

_____
Total for Region Central 15,000

Region London
GTec Systems 100,000
MacGregorTech 85,000

_____
Total for Region London 185,000

Region West Country
Dartmouth Shipping 8,000
Great Combe Systems 25,000
River Down Ltd 156,000

_____
Total for Region West Country 189,000

_____
Grand Total 389,000

For SuperReport Pro to produce the above printed output would require only a single break level using
both a SubHeader1 section and a SubTotal1 section.

The record selection also needs to be sorted on the [Customer]Region and [Customer]Name fields prior to
the report being printed otherwise the break processing will not function correctly. This can be done by
creating a Start Script for the report to sort the selection using the following code:

SORT SELECTION([Customer]; [Customer]Region;>;[Customer]Name;>)

The maximum number of SubHeader and/or SubTotal sections indicates the number of break levels that
are to be used - one in this case, since there is only one SubHeader, and one SubTotal section. If there
has been one SubHeader section used, but two SubTotal sections, then there would have been two break
levels.
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The last thing that remains when creating this report is to indicate to SuperReport Pro the field value that
SuperReport Pro is to "watch" in order to generate the correct SubHeader and SubTotal sections.

The field value (in this example) that determines when to generate the appropriate SubHeader and
SubTotal sections is the [Customer]Region field - whenever its value changes, SuperReport Pro will
generate a break level. Setting the field or variable that SuperReport is to "watch" in order to generate
breaks is described below.

Setting a SubHeader or SubTotal Section’s Breaking Value
In order to make use of SuperReport Pro's break processing capability, you must define the field or
variable that SuperReport Pro is to “watch” for each of the break levels (SubTotal1, SubTotal2 etc).
You can define the “breaking” field or variable name in either the SubHeader section, SubTotal section
or in both sections. When SuperReport Pro calculates the number of break levels, and the "breaking" field
or variables names for each level, it checks the SubTotal sections first, and then the SubHeader
sections. The reason that you can define the "breaking" field or variables names in either the SubTotal
section or the SubHeader section is because you may have a report that uses only SubHeader sections or
SubTotal sections, or a mixture of the two.

In the example above, if no subtotals for the sales figures was required, but a breakdown of the customers
by regions was, then only the SubHeader1 section might be defined - there would be no need for the
SubTotal1 section.

To set the breaking field or variable name that SuperReport Pro is to watch, either double-click on the
section marker, or select its name from the hierarchical menu that appears when you select the Modify
Section command on the Edit menu. This will produce the section options dialog shown below.
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To set the breaking field or variable name select the Only Use This Section On Value Changes Of…
radio button.

Clicking on the pop-up menu to the right of the text "Object" will allow you to specify whether the object to
be "watched" is a field, a variable or an array variable.

To select the field or variable name, click on the small pop-up menu icon between the text "Name" and the
entry field that contains the text “[Customer]Region”. Doing so will produce a pop-up menu listing the
available fields or arrays depending upon which object type you have selected. You are also able to enter the
name directly into the entry field if you so wish.

As SuperReport Pro processes the report, it will "watch" each of the specified breaking fields or variables,
and will generate a break (and print the appropriate SubHeader and SubTotal sections) when it detects
that its value has changed.

Setting the Section Options
To display the section options dialog, either double-click on the section marker within the report, or select
its name from the hierarchical menu that appears when you click on the Modify Section command on the
Edit menu. If the section you wish to modify is disabled, then this is because it has not yet been defined on
the report. For example, if you have a single break level because you have only created a SubHeader1 and
a SubTotal 1 section, then the SubHeader2 … SubHeader6 and SubTotal2 … SubTotal6 menu items
will be disabled.

The Section Options dialog will then be displayed. A complete description of setting the breaking value is
described above in the section Setting a SubHeader or SubTotal Section’s Breaking Value.

The Section Options dialog also allows you to control page breaking. Using the Page Breaking Options radio
buttons, you can determine whether the current section is to be printed on the current page, or whether a
new page is to be generated before or after the current section is printed.

The Adjust Section At Print Time For Clipping Margin checkbox is only used for the Footer
section. Checking this option causes SuperReport to automatically "lift" the footer section area, when it is
printed, above the clipping margin at the bottom of the report page. This feature is useful since it means
that you can define the height of your Footer section to accommodate your footer objects without having to
calculate the additional height required to allow for the clipping margin.
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If you do not set the Adjust Section At Print Time For Clipping Margin checkbox then the footer
objects will be printing within the page’s clipping area - ie they will not be printed.

If however the Adjust Section At Print Time For Clipping Margin checkbox is set then the Footer
section will be increased in height by the size of the clipping region at the bottom of the printed page
causing the footer objects to be printed above the clipping boundary as you would expect.

If you have defined your report in terms of the physical page and if you do not set the Adjust Section At
Print Time For Clipping Margin checkbox then you will have to set the Footer section height tall
enough to accommodate both the printer’s clipping margin and the objects that you wish to place in the
footer area of the report.

Section Scripts
SuperReport Pro allows you to attach an object script to any defined section. To access the script editor
window, click on the Script… button in the section options dialog. If the section already has a script
associated with it, or if you create a new script for the section then the text of the Script… button will be
preceded by a  (tick mark). The  (tick mark) is a quick way of seeing that an object has a script
associated with it.

When an section is viewed on the report page, it is also possible to tell whether it has a script attached to it
or not. If it does have a script, then the section marker name will be drawn with an inverted inverted
triangle at the top left hand side of the marker.

When the report is generated, section scripts are executed 'just before' their objects are printed on the
report. For example, if a Body section of a report has a script attached to it, and the report prints the
Body section five times (because the report is printing a selection of five records), then the section script
will be executed five times - each time prior to the section’s object being “printed” on the page.

Section scripts like object scripts can be used to make selections of records in other files, to fill variables
with data, or to perform any other action that the 4th Dimension command set will allow. The script editor
window that the Script… button produces is described in more detail above.
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Rulers and Guides

Rulers
The SuperReport Pro editor has a ruler that can be made visible or invisible  using the Show Rulers
command on the Options menu. When the rulers are active then the menu command will be preceded by a
tick mark. You may only create new guides on the report when the ruler is active - this is described in
greater detail below.

When a new SuperReport Pro report is created and displayed, the ruler defaults to points. The current unit
type displayed on the ruler is indicated by the Ruler Units hierarchical menu display on the Options
menu. Clicking on the menu produces a units pop-up menu from which you are able to select three possible
unit types: Points, Millimetres and Inches.

Creating a New Guide
SuperReport Pro allows you to make use of up to four horizontal and four vertical guides on a report.
Guides are used to help you align objects on the report. They may be made either visible or invisible using
the Show Guides command on the Options menu. Guides can only be created when the rulers are shown.

To create a new horizontal guide click in the horizontal ruler at the bottom of the SuperReport Pro editor
area and drag a new guide onto the report. As you drag the new guide the cursor will change to the guides
cursor shown to the left. Similarly, to create a new vertical guide click in the ruler at the right hand side
of the editor area, and drag a new vertical guide on to the report.

If there are already four horizontal guides on the report, you will be unable to drag a new horizontal guide.
By the same token, if there are already four vertical guides on the report you will be unable to drag a new
vertical guide.

Moving a Guide
To move a guide, click on it and drag its outline to a new position.

Deleting a Guide
To delete a guide (either horizontal or vertical), click on it and drag it off the report editor area - this will
cause SuperReport Pro to remove the guide from the report.
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Report Scripts

Scripts
The Scripts menu item on the SuperReport menu produces a hierarchical menu listing three menu
items. These items correspond to the three types of script that SuperReport is able to execute as the report
is generated.

The Start Script is executed before the report is generated - this procedure is normally used to load a
selection of records and to sort them prior to printing.

The Body Script is executed as each record (or element of the array) in the current selection is
processed - this procedure is normally used to load related records, or to search and sort for a selection of
records in another file.

 The End Script is called when the report has finished printing - it can be used to clear arrays of
variables that where used or to reinstate the record selection in force before SuperReport Pro generated
its report.

If the script menu item is preceded by a tick mark, then this means that the relevant script is active and
contains 4th Dimension statements, and will be executed at the appropriate time during report generation.
If the menu item is not checked then there are no 4th Dimension statements for that procedure and
SuperReport Pro will not execute any code. These three SuperReport scripts are analogous to 4th
Dimension’s report layout phases - the Start Script is equivalent to the Before Selection phase, the
Body Script is equivalent to the Before or During phase, and the End Script has no equivalent phase.

Selecting any of these menu items will produce the script editor window which is described above. A
developer is able to disable the Script menu item preventing access to the hierarchical menu.
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Report Main File Or Iterations

Unlike 4D's reports, a SuperReport Pro report contains details of the file that the report is to 'iterate'
when generating the report output. A report can either iterate using a file, or it can generate a designated
number if iterations determined by the size of an array or value in a variable (for example).

Selecting the Report File/Iterations… command from the SuperReport menu produces the dialog
shown above. Here you can specify how the report is to be generated using one of there are four radio
buttons.

Specifying a Report File
If you specify a Selected Report File, then SuperReport Pro will iterate through the current record
selection for that file when generating the report output. SuperReport Pro will issue a FIRST RECORD
before the report commences, and will issue NEXT RECORD  commands to generate each Body section.

If you wish the report to automatically make a new record selection prior to reporting, use a Start
Script to issue 4D commands to make the new selection. The Start Script will be executed before
SuperReport Pro calculates how many records there are in the current selection for the specified file.

Specifying a Fixed Number of Iterations
Specify a Fixed Number Of Iterations causes SuperReport Pro to generate a fixed number of iterations
(regardless of any file selection sizes). You might use this option when you require a designated number of
report pages.

Specifying the number of Iterations based on the value in a Variable
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Specify the Use Value In Variable option causes SuperReport Pro to generate a fixed number of
iterations determined by the numeric value contained in the variable whose name is entered in the Name
field. Generally this value will be calculated within the database before the report is selected for printing.

Specifying the number of Iterations based on the size of an Array
Specify the Use Size Of Array option causes SuperReport Pro to generate a number of iterations
determined by the size of an array whose name is entered in the Name field. This option is generally used
when printing from array selections.
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Searching and Sorting Record Selections

Making a New Record Selection
Selecting the Select Records… command will either produce the standard 4th Dimension Search editor, or a
search editor created and installed in the 4th Dimension database by the developer. This command allows you to
change the file selection prior to printing (or previewing) the report.

Sorting the Record Selection
Selecting the Sort Records… command will either produce the standard 4th Dimension Sort editor, or a sort
editor created and installed in the 4th Dimension database by the developer. This command allows you to sort
the file selection prior to printing (or previewing) the report.

You may find it more practical to use 4th Dimension statements placed in the Start Script script to search
for a new record selection, and to sort it, prior to printing the report. This has the added advantage that the
search and sort operations will be remembered the next time the report is generated.
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Loading and Saving Reports

Loading Reports
Generally reports will be automatically loaded in the SuperReport Pro editor for you (the developer will have
used code within the 4D database to do this for you automatically). However, using the Open…  command on the
File menu, you are able to load reports directly from disk.

Saving Reports
Generally reports will be automatically saved for you when you quit the SuperReport Pro editor. However, you
can use the Save and Save As…  commands on the File menu to save the report as a document on disk.

Having done so, you will later be able to re-load the report using the Open…  command on the File menu.
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Printing SuperReport Reports

Print Preview
Selecting the Print Preview command from the File menu will cause SuperReport Pro to preview the
report within the SupeReport Pro editor area. The area will change providing you with a new toolbar
containing page navigation buttons, a Print button and a Done button (used to return to the report editor).

As SuperReport Pro previews the report, a thermometer provides an indication of how far through the
record (or array) selection the preview has progressed. The preview stops as each page is generated, and
you need to select the next page button (third icon from the left) to generate the next page.

Using the other navigation buttons, you can step backwards and forwards through the generated pages. The
page navigation buttons can be activated using the Command key and the arrow (cursor) keys. The Print
button prints the current viewed page. If you need to print all the pages, terminate the preview using the
Done button (with a 'cross' in it), and print the report normally using the Print command from the File
menu.
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If you click within the 'mini' printed page (in preview mode), SuperReport Pro will 'zoom' the page to
100% allowing you to see the report page as it would print. Using the scrollbars, you are able to move the
page around. You can also hold down the Option (Alt) and Command (Apple) keys, and drag the page using
the mouse.

If you find that the preview produces no visible output, then make sure that you have one or more items in
your current selection for printing. If not, you can use the Select Records… command from the
SuperReport menu. Also ensure that you have defined your report correctly, with the sections in the
appropriate place.

Print To Disk
This facility is provided to allow you to create export documents on disk using SuperReport Pro. The output
is in the form of an ASCII file, and SuperReport Pro will display the following dialog displaying the output
options available to you.
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Using the dialog, you are able to select the sections for printing - normally you would only print the Body
section, however you do have the option to print all the sections (as defined in the Select Printing
Sections… dialog).

The Print Static Text Items allows you to either print or suppress static text (such as heading etc.)
depending upon whether you check the check box or not.

Using the Between Fields and End Of Record edit fields, you can specify the ASCII value of any
character that you wish to have printed between fields, and sections. By default, these are the TAB and
carriage return characters (respectively).

If you select the Print button, SuperReport Pro will prompt you to create a document. If you do not create
a document using the standard save file dialog, then SuperReport Pro will not print the report to disk. If
you do create a document, then SuperReport Pro will print the report to disk in your specified document.

Selecting Printing Sections
Generally you will always print the sections that you have defined on your report. However, SuperReport
Pro has a very useful feature that allows you to "switch off" certain sections suppressing them from the
printed output even though they are defined on the report.
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This feature is most useful for reports that make use of break processing where you want to design a single
report, but need to print it either with or without the Body section. This allows a single report to be
printed as two different reports; a detailed report, or a summary report only.

Note that even when sections are "switch off", all the object and section scripts within that section are still
executed a print time.
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